When I try to play a class on my Kindle Fire it says "plug in is not supported".

I am sorry that you are having this issue and am happy to assist you. To get rid of this error message you'll need to enable the flash player on your Kindle. Here's how to do that: http://www.technipages.com/kindle-fire-how-to-enable-or-disable-flash-in-the-browser.html
 

Did you find this article helpful?